|
border_tl border_tr
Recurring credential prompt on Exchange 2007 connected via HTTPs or HTPPs enabled connected locally? Minimize

Oliver Sommer 
2008-09-29
edited 2010-02-18

Remark:
This issue should be gonne as soon as you update your exchange servers with the latest servicepacks and Patches using Microsoft Update.
Guess what: This issue just respawned by one of the latest KB/MS Patches.
 
Under certain circumstances you might be facing the same issue we had while connecting out Outlook Clients to EBS (might also hit users of Standard product SKUs).

We have had the issue that Outlook keeps asking for Credentials on and on and doesn’t seem to stop or just stops prompting for username and password for days, but will suddenly (mostly after server reboots) restart asking for creds again.

After numerous troubleshooting sessions we (at least some brave folk from MS India) seem to have got the solution to that annoying issue:

As soon as we run the following CMDs in an elevated command prompt on the EBS Messaging Serer (Exchange 2007 with Client access [CAS] and Mailbox role enabled) the recurring cred prompt disappeared:
%windir%\System32\inetsrv\appcmd.exe unlock config -section:system.webServer/security/authentication/windowsAuthentication
%windir%\System32\inetsrv\appcmd.exe set config "Default Web Site/ews" -section:windowsAuthentication -useKernelMode:False /commit:apphost
%windir%\System32\inetsrv\appcmd.exe set config "Default Web Site/AutoDiscover" -section:windowsAuthentication -useKernelMode:False /commit:apphost
%windir%\System32\inetsrv\appcmd.exe set config "Default Web Site/oab" -section:windowsAuthentication -useKernelMode:False /commit:apphost

Investigations on why this is not working as it should for us and some others are still been processed to maybe find the root cause and fix it.

added at February 18th
Due to further investigations and another KB Patch recently rolled out by Microsoft (KB 973917) in addition to the upper Commands you need to enter the following command as well:

%windir%\System32\inetsrv\appcmd.exe set config -section:windowsAuthentication /useKernelMode:false

Thanks for Damian and the other SBS CSS PG Team members who told me that personaly and also just bloged about it: http://blogs.technet.com/sbs/archive/2010/02/16/outlook-2007-credential-prompts-in-small-business-server-2008.aspx)

 

 Print  
Feedback Maximize

border_bl border_br
©2007 EBSfaq.com. All rights reserved.This is not a Microsoft site,it's community. Hosted by 3can.de Terms Of Use Privacy Statement